Email sending delays
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 09, 2017 - 09:27 PDT
Monitoring
Our email provider has solved the issues, email sending should go back to normal.
Posted 6 months ago. Apr 09, 2017 - 09:14 PDT
Investigating
We detected some errors with our email provider that are causing delays on email sending.
Posted 6 months ago. Apr 09, 2017 - 08:16 PDT