Elevated Timeouts
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 22, 2017 - 13:41 PDT
Investigating
We are currently experiencing an elevated number of request timeouts. We are investigating the issue and will update the status as soon as we have more information.
Posted 5 months ago. Apr 22, 2017 - 12:52 PDT