Service unavailable
Incident Report for ConvertKit
Resolved
The issue is resolved now!
Posted about 2 months ago. Mar 02, 2017 - 13:56 PST
Update
We're investigating what's going on!
Posted about 2 months ago. Mar 02, 2017 - 13:48 PST
Investigating
We are currently experiencing an elevated number of request timeouts. We are investigating the issue and will update the status as soon as we have more information.
Posted about 2 months ago. Mar 02, 2017 - 13:43 PST