Delays on sequence sending
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted about 1 month ago. Jan 19, 2018 - 11:31 PST
Identified
Sequences email sending is delayed due to an unexpected maintenance window by our service provider.
We are working on a fix.
Posted about 1 month ago. Jan 19, 2018 - 11:21 PST