Elevated Timeouts
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 8 months ago. Oct 16, 2017 - 05:15 PDT
Investigating
We are currently experiencing an elevated number of request timeouts. We are investigating the issue and will update the status as soon as we have more information.
Posted 8 months ago. Oct 16, 2017 - 05:13 PDT