High response time
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 10, 2018 - 11:48 PDT
Investigating
We're currently experiencing higher-than-normal response time. We are investigating the issue and will update when we know more.
Posted 6 months ago. Jun 10, 2018 - 11:39 PDT