High response time
Incident Report for ConvertKit
Resolved
Response times have returned to normal
Posted 6 months ago. Dec 22, 2017 - 13:27 PST
Investigating
We're currently experiencing higher-than-normal response time. We are investigating the issue and will update when we know more.
Posted 6 months ago. Dec 22, 2017 - 13:08 PST