High response time
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 4 months ago. Sep 13, 2017 - 22:51 PDT
Investigating
We're currently experiencing higher-than-normal response time. We are investigating the issue and will update when we know more.
Posted 4 months ago. Sep 13, 2017 - 22:48 PDT