Elevated Timeouts
Incident Report for ConvertKit
Resolved
Request times have returned to normal.
Posted about 1 year ago. Dec 05, 2017 - 20:09 PST
Investigating
We are currently experiencing an elevated number of request timeouts. We are investigating the issue and will update the status as soon as we have more information.
Posted about 1 year ago. Dec 05, 2017 - 16:05 PST