High response time
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted about 1 year ago. Dec 18, 2017 - 07:49 PST
Investigating
We're currently experiencing higher-than-normal response time. We are investigating the issue and will update when we know more.
Posted about 1 year ago. Dec 18, 2017 - 07:48 PST