High response time
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 14 days ago. Apr 11, 2017 - 10:28 PDT
Investigating
We're currently experiencing higher-than-normal response time. We are investigating the issue and will update when we know more.
Posted 14 days ago. Apr 11, 2017 - 10:08 PDT