Elevated Timeouts
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 2 months ago. May 10, 2018 - 18:32 PDT
Investigating
We are currently experiencing an elevated number of request timeouts. We are investigating the issue and will update the status as soon as we have more information.
Posted 2 months ago. May 10, 2018 - 18:13 PDT