Delays in Broadcast sending
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 7 months ago. May 08, 2017 - 04:45 PDT
Monitoring
We deployed a fix and are monitoring email sending.
Posted 7 months ago. May 08, 2017 - 04:18 PDT
Investigating
We're experiencing some broadcast email sending delays. We're investigating.
Posted 7 months ago. May 08, 2017 - 02:03 PDT