Elevated Timeouts
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 06, 2017 - 13:01 PDT
Investigating
We are currently experiencing an elevated number of request timeouts. We are investigating the issue and will update the status as soon as we have more information.
Posted 6 months ago. Jun 06, 2017 - 11:33 PDT