Elevated Timeouts
Incident Report for ConvertKit
Resolved
Maintenance work caused timeouts.
Posted 6 months ago. May 19, 2017 - 00:31 PDT
Investigating
We are currently experiencing an elevated number of request timeouts. We are investigating the issue and will update the status as soon as we have more information.
Posted 6 months ago. May 19, 2017 - 00:25 PDT