Elevated Timeouts
Incident Report for ConvertKit
Resolved
Application and API performance have returned to normal.
Posted 7 months ago. Nov 16, 2017 - 13:39 PST
Investigating
We are currently experiencing an elevated number of request timeouts. We are investigating the issue and will update the status as soon as we have more information.
Posted 7 months ago. Nov 16, 2017 - 10:30 PST