Scheduled maintenance tomorrow (2/27) at 4am EST / 9am GMT for up to 30 minutes
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 27, 2017 - 01:56 PST
Monitoring
Forms, new subscriptions, open/click/unsubscribe tracking will still work during maintenance, although they could be delayed. Your dashboard will be unavailable.
Posted about 2 months ago. Feb 26, 2017 - 09:52 PST