We are experiencing connectivity issue with one of our infrastructure provider
Incident Report for ConvertKit
Resolved
Between 11:47 AM and 12:33 PM PDT we experienced increased error rates for Amazon S3 requests in the US-EAST-2 Region. The issue has been resolved and the service is operating normally.
Posted about 1 month ago. Oct 05, 2018 - 12:58 PDT
Update
We're investigating the scope of the affected service.
Posted about 1 month ago. Oct 05, 2018 - 12:22 PDT
Investigating
We are looking into an issue that affects some of our features like forms creation, image upload, document uploads.

Seems like one of our infrastructure provider is having connectivity issue.

We are investigating the situation.
Posted about 1 month ago. Oct 05, 2018 - 12:21 PDT
This incident affected: Application.