SSL Certificate Issuer Service Disruption
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted Jun 26, 2020 - 14:49 PDT
Monitoring
Our SSL certificate issuer is under maintenance but functionality has returned. Now we are able to issue SSL certificates for custom domains but we're continuing to monitor the situation.
Posted Jun 26, 2020 - 13:31 PDT
Identified
Our SSL certificate issuer is currently experiencing issues. During this time we are unable to issue SSL certificates for new custom domains.
Posted Jun 26, 2020 - 13:04 PDT