Issues with links in emails
Incident Report for ConvertKit
Resolved
We're continuing to monitor, but the DNS change will continue to propagate and bring us to full resolution over time.
Posted 5 months ago. May 24, 2019 - 06:42 PDT
Monitoring
We are continuing to see issues with links in emails for a subset of customers. We have resolved the issue for new emails sent, and have changed our DNS settings so that links in older emails will continue to work. However, it will take up to 48 hours for that change to take effect.

The core issue is that DNS stopped resolving for link.m.convertkit.com on Thursday May 23rd at round 10PM UTC. After triaging, we set up m.convertkit.com using a new hosted zone, and that fix did work. However, our nameserver caching was set to 48 hours, which means that other DNS systems won't update their records for at most that amount of time. We're continuing to push our hosting provider to give us details about why the failure occurred on their end, and to see if they can correct the issue to fix link clicks for subscribers who are still seeing DNS issues.

Additionally, we have changed the url for links in emails going forward to not use the subdomain that is having problems.

We will update the incident as we get more information from our hosting provider.
Posted 5 months ago. May 24, 2019 - 06:26 PDT
This incident affected: Email sending.