Our hosting provider is currently having DNS issues.
Incident Report for ConvertKit
Resolved
The DNS hosting issue is now resolved. If you are still experiencing problems please clear your browser cache and restart your browser.
Posted Oct 22, 2019 - 16:13 PDT
Identified
Our hosting provider is currently having DNS issues that is affecting the ConvertKit app. Our engineers are working on a mitigation strategy.
Posted Oct 22, 2019 - 13:10 PDT
This incident affected: Application and Integrations.