System-wide issue
Incident Report for ConvertKit
Resolved
This incident has been resolved
Posted Apr 19, 2024 - 09:01 PDT
Monitoring
The app is back up, there might some delays in functionality. We're monitoring and will update
Posted Apr 19, 2024 - 08:41 PDT
Investigating
We are experiencing system wide issues, currently investigating.

We will update as we investigate.
Posted Apr 19, 2024 - 08:16 PDT
This incident affected: Application.