High response time
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 04, 2017 - 02:39 PDT
Investigating
We're currently experiencing higher-than-normal response time. We are investigating the issue and will update when we know more.
Posted 3 months ago. Sep 04, 2017 - 02:37 PDT