Elevated Timeouts
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 9 months ago. Oct 05, 2017 - 06:32 PDT
Investigating
We are currently experiencing an elevated number of request timeouts. We are investigating the issue and will update the status as soon as we have more information.
Posted 9 months ago. Oct 05, 2017 - 06:31 PDT