High response time
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 15 days ago. Apr 10, 2017 - 09:11 PDT
Investigating
We're currently experiencing higher-than-normal response time. We are investigating the issue and will update when we know more.
Posted 15 days ago. Apr 10, 2017 - 09:09 PDT