High response time
Incident Report for ConvertKit
Resolved
This incident has been resolved.
Posted 11 months ago. Oct 24, 2017 - 21:41 PDT
Investigating
We're currently experiencing higher-than-normal response time. We are investigating the issue and will update when we know more.
Posted 11 months ago. Oct 24, 2017 - 21:35 PDT